Bug/error alex testnet

I have some experience after trying almost all features in ALEX testnet.

BUGS/ERROR :
1)There was a failed connection or unable to connect to the wallet the first time I interacted here, estimated to fail about 5 times I tried to “connect wallet” but it didn’t work. The UI doesn’t seem to be responding while the process in the HIRO wallet states success.
MY SOLUTION: I tried repeatedly to connect until it finally worked.

  1. There was a problem with the deposit, I deposited 10000 XUSD for the first time, then confirmed it at HIRO WALLET and after that there was no change, my balance still didn’t decrease, there was no transaction history, the pop-up that said there was no error either. this confuses me a lot. things like this happen repeatedly, I counted 3 times the XUSD deposit tried to experience the same thing as I described.
    MY SOLUTION: after I waited too long for nothing to change, I tried exiting the browser and clearing the cache then logging back in, then trying to deposit again and it worked.

  2. The problem occurred when I BUY on the pairs XBTC/XUSD, ALEX/XUSD, STX/XUSD.
    The first time I bought was XBTC, I set the price based on the price in the orderbook, hoping that my order was completed on time and on target, but what happened was that there was no transaction, while I confirmed the transaction in the wallet but the XBTC balance remained (0) and the transaction history was empty.
    When I buy STX, the STX/XUSD pair appears an error pop-up saying “limit buy order created failed” this also happens repeatedly.
    this problem occurs in every existing pair and the problem is the same.
    MY SOLUTION : I tried to refresh the page again and again and then tried to buy again, although the same problem persisted, but in the end the transaction was successful.

  3. The SELL feature also has an error, the problem is almost the same as when BUY, it’s just that in this SELL feature what often happens is a pop-up error appears on the screen saying “limit sell order create failed” in this SELL session I spent a long time waiting for this to work, because the error occurred repeatedly. My solutions such as refreshing the page or clearing the cache are also less efficient, until it works.

  4. There was a problem with the transaction history feature, I SELL the STX/XUSD pair several times and it didn’t work, problems like the point above, the transaction was executed in the wallet but there was no change in the balance like not responding to anything.
    Then what’s the other problem??
    the problem is that after I made the sell transaction, I refreshed the page and the transaction history appeared in the “MATCHED ORDERS” section but the history was unusual, (the evidence is in the screenshot). the history looks faint / the font doesn’t light up like the other histories. then I tried to check in the trade history section, there was no transaction with the pair. until I refresh the page again but the transaction is still not in the TRADE HISTORY section.

Mainnet address : {SP1DWBP0EDQQ198Y1N2ARZQFMNYKBZEJ21T8182VN}
Testnet address : {ST1DWBP0EDQQ198Y1N2ARZQFMNYKBZEJ21RFG9AG5}

device : Android 10

Thanks for your feedback.
Can you provide screenshots for your sell and buy functions? We will take a look for details.

1 Like

Yesterday I also attached photos and videos on discord.