UPDATE - Internal 500 Error after connecting ETH wallet - UPDATE - This error vanished after the latest server reset

ETH Test Address: {0xd08496a1B8B2bEa375a4E9F76201107661e61bac}
Descriptions: {Internal 500 error after connecting ETH wallet}

This error occurs the moment I connect ETH wallet - After searching this forum and all discord, it seems my browser is the only one having this issue - the bridge is working fine.
I’ve been stumped with this error for few days - working earlier today was able to test and connect the bridge on a different PC with same config → Brave browser ETH wallet + HIro wallet setup.
Attempted a few things: Brave Browser pages were cleared/hard reset, Goerli network reset and settings checked, ALEX test network settting checked. Brave wallet send/receive checked.
What could I be missing? Thanks for any suggestions in advance!



Discord ID: {DeeList.btc#2834}
Telegram ID: {@DeeList_btc}
Browser: Brave Version 1.45.131 Chromium: 107.0.5304.110 (Official Build) (64-bit)

1 Like

Hi DeeList.btc,
With me, this error has not appeared.
Maybe it’s a matter of error / problem with Metamask plugin in this particular browser and on this comp?
Have you tried reinstalling the plugin there?


1 Like

I have received this error before, however it comes right after trying an hour or so later.

I haven’t figured what exactly causes it.


Hi W1K,
thanks for your feedback :+1:



Thank you @mike_bear_1 - Yes, I think the same - problem is with my particular PC wallet/browser. On further testing and able to successfully connect same wallet with many other networks/apps, not sure why the error. Also wonder how this error developed.
Agree that a reinstall would more than likely fix, bringing forward in hopes to help prevent whatever caused so no wallet resets or reinstalls are necessary in future. Waiting for devs input on this before any moves.
Cheers! :beers:


Thank you for posting!

Can you share any further details on these few questions?

Was it the same ‘internal 500’ error message in my screenshot above?
Did the error also only happen after you connected your Ethereum wallet?

Please add anything else you can think of, thank you!


Alright @DeeList.btc, good to see you acting and pay attention to details when testing.
And you too @W1K, thanks for acting as well.
Because other than that, we don’t have much reporting right now.
But testing requires regularity and continuity.
Thank you :handshake:

1 Like

Stacks Testnet: ST37N35P4903CB8S91SHHYYQ3Q44Q3HCJS8RD4TKW
Stacks Mainnet: SP37N35P4903CB8S91SHHYYQ3Q44Q3HCJSBP8DCVF
Discord: NuriKols#4750
Telegram: @ WaseemK

So I’ve tracked down the following error:

  • Connect Metamask to any chain other than Goerli (I tested with Ethereum Mainnet, RSK Mainnet and BSC Testnet).
  • Attempt to input an amount in the bridge.
  • Site crashes with the error as shown in the above picture.

Note: Site only crashes when attempting to input a value (I only tried STX to XUSD because I had no balance on the other side yet).

Even though the error says “unsupported”, I think that instead of getting bombed out completely with the code language in the image and having to refresh / go back home, there should be a neat error message which just informs the user as to why the Wrap/Unwrap button is locked.

The error shown in the image and the site bombing out can be circumvented by changing the RPC network after already having inputted an amount to bridge.
In doing so, the amount shown on the right gets locked no matter what value is inputted on the left as shown below:


At this point, if I switch back to Goerli, the locked amount shown on the right in the image unlocks and reflects correctly.

On a different topic, I noticed something cool, see below :slight_smile:

The amount input field allows for really massive whales to input really big numbers.
This amount input can be capped at some amount.
Also, the input field indefinitely expands.

Here’s something more cool:

Up to this amount (number of digits), the screen indefinitely expands:

and at just $1 more (1 character more) 1,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,000,001) the screen resets and looks like this:

Note the infinity sign.

After clicking the Wrap/Unwrap button, it appears that only the left field expands as explained previously:

The same occurs, whether on Goerli or not:

1 Like

If you try going to the bridge site while on an incorrect RPC network, you receive the following error message:

Uploading: image.png…

Thanks @W1K ,

Nice work and great finds!
The site crash error you mention here is known & previously reported https://gov.alexlab.co/t/website-error-page/5363/7?u=deelist.btc
The error searching for now needs to be the same ‘Internal 500’ error seen my screenshot and description.
Please create a post for any new or different errors you find so they are not overlooked, also helps us keep things organized.
@mike_bear_1 Do any of these reported expands look familiar? I know you were testing max inputs also.


Yes @DeeList.btc I associate that I wrote back some time ago on the topic about the maximum amount possible to enter in a transaction on STX Bridge.
Ultimately, this is verified with the balance of funds in the wallet before execution. In case of insufficient funds, the transaction will not go through.
But on the other hand, it doesn’t look good, and I think that such verification (amount entered vs. funds on the wallet) should be at the stage of entering the amount in STX Bridge.

As for testing, it’s true that it’s better to avoid repeated submissions. Sometimes, however, after a reset of the application, it is good to repeat the same tests (regression) and make sure that everything works ok. If you then find an error, it is worth reporting it, indicating that it is an observation after a reset of the application.
This is how I would see it.
Thank you :handshake:


Yes, much better to find the cause of this error beforehand than not.
This case now it’s important to first know, before any such major wallet reset or action if the script is cause or from which end this problem originated. It would be unwise to first reset without further input from the devs end if this is completely necessary, devs may need and request vital information/details of this error in current state. Not knowing if a reset will fix also risks the chance of being unable to/or not easily reproducing any error details we have now. This may possibly not be a necessary reset condition and a simple scripting mismatch.
From this, we will also know how to proceed if others report same or the error returns.
Look forward to hearing devs input, Thank you @mike_bear_1 :muscle:


Absolutely right @DeeList.btc
By testing we check and confirm (or not) the quality of the software / application.
And for the testers feedback from Devs is an absolute must have, I think :thinking:


UPDATE - This is no longer an issue after the server reset. Wallet function restored.
Thanks everyone.